GAEA

   
Submit a request
  

What are the system requirements of IOS?

Ming Lin -

For iOS: It is Compatible with iPhone 7, 6, 5, 4, iPod Touch and iPad.

Requires iOS 4.3 or later for full functionality.

Have more questions? Submit a request

Comments

Powered by Zendesk